技术交流QQ群:①185473046   ②190706903   ③203744115   网站地图
登录注册

下次自动登录
现在的位置: 首页PHP>正文
CentOS服务器单独升级 php5.1 到 5.2版本
2011年10月23日 PHP 暂无评论 ⁄ 被围观 4,522次+

引言:使用CentOS 5.5系统的朋友们都知道,yum默认安装的php版本为php5.1,我们要想使用最新的稳定版本(php5.2.x系列),就必须编译安装。

下面教大家如何使用yum来选择安装自己需要的php版本!

以下操作均在终端命令行下进行!

      系统运维  www.osyunwei.com  温馨提醒:qihang01原创内容©版权所有,转载请注明出处及原文链接

rpm --import  http://repo.webtatic.com/yum/RPM-GPG-KEY-webtatic-andy
wget -P /etc/yum.repos.d/  http://repo.webtatic.com/yum/webtatic.repo
yum --enablerepo=webtatic list php   #发现有php5.2 和 php5.3可以升级
yum --enablerepo=webtatic --exclude=php*5.3* list php     #查看php5.2软件包
yum --enablerepo=webtatic --exclude=php*5.3* update -y php     #安装php5.2版本
注:选项--exclude=php*5.3*     #禁止升级为php5.3版本

扩展:上面所讲是是如何定制升级php,同理此方法也可以用于安装其他的软件,例如mysql,大家可以自行测试!

     

  系统运维技术交流QQ群:①185473046 系统运维技术交流□Ⅰ ②190706903 系统运维技术交流™Ⅱ ③203744115 系统运维技术交流™Ⅲ

给我留言

您必须 [ 登录 ] 才能发表留言!



Copyright© 2011-2017 系统运维 All rights reserved
版权声明:本站所有文章均为作者原创内容,如需转载,请注明出处及原文链接