技术交流QQ群:①185473046   ②190706903   ③203744115   网站地图
登录

下次自动登录
现在的位置: 首页Switch>正文
华为交换机基本配置案例
2022年05月22日 Switch 暂无评论 ⁄ 被围观 590次+

1、初次登录交换机

使用Console通信电缆(产品随设备附带)连接交换机与PC。若PC无串口,需要使用USB接口转串口的转接线。

PC上打开终端仿真软件,新建连接,设置连接的接口以及通信参数。

连接的接口请根据实际情况进行选择。例如,在Windows系统中,可以通过在“设备管理器”中查看端口信息,选择连接的接口。

交换机上的通信参数:

传输速率  9600bit/s

流控方式  不进行流控

校验方式  不进行校验

停止位  1

数据位  8

1.1登录交换机,出现下面的界面(S7700系列交换机)

Connecting to COM4...

Connected.

Login authentication

Username:admin

Password:admin@huawei.com

Warning: The default password poses security risks.

The password needs to be changed. Change now? [Y/N]: y

Please enter old password:admin@huawei.com

Please enter new password:Admin@huawei.com

Please confirm new password:Admin@huawei.com

The password has been changed successfully.

Info: Lastest accessed IP: Invalid IP address Time: 2022-05-11 16:29:50+08:00 Failed: 6

<Quidway>

#华为 Quidway S7700系列交换机Console控制台默认登录

账号:admin

密码:admin@huawei.com

#初次登录成功后会提示修改默认密码,建议输入y修改密码。

1.2登录交换机,出现下面的界面(S5735S系列交换机)

User interface con0 is available

Please Press ENTER.

An initial password is required for the first login via the console.

Set a password and keep it safe. Otherwise you will not be able to login via the console.

Please configure the login password (8-16)

Enter Password:Admin@huawei.com

Confirm Password:Admin@huawei.com

Warning: The authentication mode was changed to password authentication and the user level was changed to 15 on con0 at the first user login.

Warning: There is a risk on the user-interface which you login through. Please change the configuration of the user-interface as soon as possible.

Info: Smart-upgrade is currently disabled. Enable Smart-upgrade to get recommended version information.

<FutureMatrix>

#华为 FutureMatrix S5735S系列交换机Console控制台默认登录

默认没有账号和密码,必须设置一个密码,否则将无法通过控制台登录。

2、交换机Vlan基本配置

<Huawei>display version #查看设备信息,软件版本、设备型号、运行时间

<Huawei>display diagnostic-information #显示设备所有状态信息

<Huawei>display interface brief  #查看接口

<Huawei>system-view #进入系统视图

<Huawei>reset saved-configuration #在用户视图下初始化配置信息,输入y

<Huawei>reboot #输入n,再输入y重启交换机,重启完成之后所有配置全部已清空

#配置vlan

<Huawei>display vlan #查看vlan信息,默认所有端口都在vlan1,vlan1不能删除和修改

<Huawei>display vlan summary #查看vlan信息

<Huawei>display port vlan #查看vlan信息

<Huawei>undo terminal monitor #关闭终端显示调试/日志/告警信息功能

<Huawei>system-view #进入系统视图

[Huawei]vlan 2 #创建vlan2

[Huawei-vlan2]description server #设置vlan2名称

[Huawei-vlan2]port-group 2 #创建端口组2

[Huawei-port-group-2]group-member GigabitEthernet0/0/1 to GigabitEthernet0/0/20 #将端口g0/0/1-g0/0/20加入到端口组2

#注意GigabitEthernet是千兆以太网接口,XGigabitEthernet是万兆以太网接口

[Huawei-port-group-2]port link-type access #配置端口组模式为接入access

[Huawei-port-group-2]port default vlan 2 #将当前端口组2加入到vlan2中

[Huawei-port-group-2]quit #退出vlan

[Huawei]display vlan #查看vlan信息

#给vlan配置ip地址

[Huawei]interface vlanif 2 #进入VLANIF接口视图

[Huawei-Vlanif2]ip address 192.168.1.1  255.255.255.0  #设置vlan2接口的ip地址(vlan2网关地址)

[Huawei-Vlanif2]quit #退出

[Huawei]display ip routing-table #查看路由表

[Huawei]display ip interface brief #查看路由表

[Huawei]sysname S5735S #修改设备名称为S5735S

[S5735S]quit #退出系统视图

<S5735S>save #输入y保存当前配置信息

<S5735S>reboot #输入y重启交换机

<S5735S>display saved-configuration #显示flash中保存的配置文件

<S5735S>display current-configuration #显示当前配置信息

3、两台交换机端口聚合配置

第一台:

<Huawei>system-view #进入系统视图

<Huawei>undo terminal monitor #关闭终端显示调试/日志/告警信息功能

[Huawei]interface Eth-Trunk 1 #创建链路聚合端口

[Huawei-Eth-Trunk1]description TO-HeXinSwitch #设置名称

[Huawei-Eth-Trunk1]port link-type trunk #设置端口模式为trunk

[Huawei-Eth-Trunk1]port trunk allow-pass vlan 1000 1001 2000 #允许vlan通过

[Huawei-Eth-Trunk1]interface GigabitEthernet0/0/1 #进入GigabitEthernet0/0/1端口

[Huawei-GigabitEthernet0/0/1]eth-trunk 1 #将端口加入到eth-trunk 1

[Huawei-GigabitEthernet0/0/1]interface GigabitEthernet0/0/2 #进入GigabitEthernet0/0/1端口

[Huawei-GigabitEthernet0/0/2]eth-trunk 1 #将端口加入到eth-trunk 1

[Huawei-GigabitEthernet0/0/2]dis trunkmembership eth-trunk 1 #查看eth-trunk 1

[Huawei-GigabitEthernet0/0/2]dis eth-trunk 1 #查看eth-trunk 1

[Huawei-GigabitEthernet0/0/2]vlan 1001 #创建vlan

[Huawei-vlan1001]interface vlanif 1001 #进入vlanif模式

[Huawei-Vlanif1001]ip address 192.168.0.1 255.255.255.0 #设置vlanif虚接口ip地址

[Huawei-Vlanif1001]display ip routing-table #查看路由表

[Huawei-Vlanif1001]display ip interface brief #查看路由表

[Huawei]sysname sw1 #修改设备名称为sw1

[sw1]quit #退出系统视图

<sw1>save #输入y保存当前配置信息

<sw1>reboot #输入y重启交换机

<sw1>display saved-configuration #显示flash中保存的配置文件

<sw1>display current-configuration #显示当前配置信息

第二台:配置和第一台一样,把ip地址修改为ip address 192.168.0.2 255.255.255.0

#测试端口聚合

在<sw1>上ping<sw2>的ip

<sw1>ping -c 1000 192.168.0.2

断开2台交换机其中的任意一根线,观看链路情况,发现链路正常,端口聚合配置成功。

4、三层交换机添加路由

[Huawei]ip route-static  172.16.1.1  255.255.0.0  192.168.1.1

5、配置交换机远程ssh登录

[Huawei]stelnet server enable #开启ssh服务

[Huawei]rsa local-key-pair create #创建本地密钥对

[Huawei]ssh user user #创建ssh用户名为user

[Huawei]ssh user user authentication-type password #创建用户认证为密码认证

[Huawei]ssh user user service-type stelnet #服务类型为ssh

[Huawei]aaa #进入aaa模式

[Huawei-aaa]local-user user password cipher admin@huawei.com #配置用户密码

[Huawei-aaa]local-user user privilege level 15 #配置用户权限级别

[Huawei-aaa]local-user user service-type ssh #允许用户ssh访问权限

[Huawei-aaa]user-interface vty 0 4 #配置VTY

[Huawei-ui-vty0-4]authentication-mode aaa #身份认证方式为AAA认证

[Huawei-ui-vty0-4]protocol inbound ssh #允许用户以SSH的方式接入

[Huawei-ui-vty0-4]ssh server-source all-interface #有些高版本的系统禁止从所有接口远程登陆,所以我们要允许登录

[Huawei-ui-vty0-4]ssh server port 222 #修改ssh默认端口

#注意cipher和irreversible-cipher两个参数,华为的eNSP s5700系列不支持irreversible-cipher参数

[Huawei]local-user user password irreversible-cipher admin@huawei.com

#从ssh工具远程连接交换机任意vlanif地址即可登录交换机

     
» 转载请注明来源:系统运维 » 华为交换机基本配置案例

  系统运维技术交流QQ群:①185473046 系统运维技术交流□Ⅰ ②190706903 系统运维技术交流™Ⅱ ③203744115 系统运维技术交流™Ⅲ

给我留言

您必须 [ 登录 ] 才能发表留言!



Copyright© 2011-2022 系统运维 All rights reserved
版权声明:本站所有文章均为作者原创内容,如需转载,请注明出处及原文链接